Can't connect to my RTMP server

I'm running WC Go on my iPhone 6s.  I am able to stream a test broadcast to my Youtube account.  But I am unable to connect to my main RTMP server.  I've tried multiple combinations of entries for my URL without success.  I know my credentials are valid since I can stream via WireCast on my iMac with the same settings.  I always get the message, "Unable to connect.  The RTMP server did not respond to a connection request."  I have no idea how to further troubleshoot this problem.  My RTMP URL is in the format of "rtmp://s#.streamcp.com:####/####", where the "#" represents numerical values.  The final 4 numerical values represent my stream and also my username which are identical.

13replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • As a test, see if you can connect to YouTube using RTMP instead of our built in setup. That will let you know if the issue is using RTMP or related to your server.

    It's hard to know if everything is filled out correctly from your description. For example Description and Stream Name fields are required. Some CDNs require a streamkey to be added.

    Like
  • CraigS,

    Thanks for your response.  I have no idea how to connect to YouTube using RTMP.  It has become very clear to me that I am not knowledgeable enough in this area of technology to work this out.  I can connect and stream using RTMP with WireCast Pro.  If the credentials for WC Pro don't work with WireCast Go then I don't know what else to do.  The amount of time I've already spent trying to get this to work isn't worth the potential benefits of the app for me.

    I appreciate the time you've taken to try to help me.

    John

    Like
  • Do you have an IT person you can work with? 
    There really should be any difference but you have to make sure things are filled out correctly. Keep in mind that Wirecast GO is using your phone's LTE connection so it may be a server side setting that needs to change because you'd be coming from a different IP address. Otherwise the only other way I can imagine testing would be if you gave someone access to your account so they could test.

    To stream to YouTube using RTMP you just get this info from your account.


    Like
  • I have no IT support.  I am a one man show.  

    After some trial and error I was able to stream to my YouTube account using RTMP. I discovered some useful information in setting up the YouTube RTMP method. The entry area for the URL in WC Go is misleading. If you enter the address prefixed with "rtmp://" (as the field suggests you should enter it) it will not work. I had to enter my YouTube ramp URL as "a.rtmp.youtube.com/live2", excluding the preceding "rtmp://". This results in a URL that allows me to connect:

    rtmp://a.rtmp.youtube.com:1935/live2-streamname/key

    This discovery caused me to try to enter my live streaming server information the same way, not including the preceding "rtmp://".  I noticed in the final configuration that this is the URL that results---  

    rtmp://s2.streamcp.com:1935/username-streamname

    I notice that the password is not included in the URL. Could this explain failure to connect?

    John

    Like
  • In my URL configuration I posted with my last post ( rtmp://s2.streamcp.com:1935/username-streamname), I'm not sure which order the username and stream name appear since they are identical values. In other words, the URL might actually be:    rtmp://s2.streamcp.com:1935/streamname-username  

    Like
  • I apologize that it is confusing. We may need to write better instructions. It seems you have it working now.

    Like
  • I didn't mean to give the impression that I "have it working now".  I don't.  I can connect to YouTube with rtmp, but I still cannot connect to my primary streaming server.  I still get the error message about not being able to contact the server.

    I might contact tech support for the content streaming service that I use and see if they might have any ideas.

    John

    Like
  • Sorry to hear you're still having a problem. If you can connect to YouTube through RTMP it would mean that the RTMP function is generally working. There's probably some information you need to enter specific to your streaming service. Please do contact them and see what they recommend. 

    Like
  • John Baughman I am having the same issue that you are. Did you ever get it to work?

    Like
  • Suzanne,

    unfortunately I never got this to work and for the moment Ive given up on it. I may revisit this again when I have time to devote to it. Good luck. 

    Like
  • Suzanne Colbert Please do post the details.

    Like
  • Hello, did you revisit this issue?  I'm having the same issue. 

    Like
  • Will Johnson Wirecast Go has been updated to Wirecast Go 2. Please test and start a new thread since it's a different version.

    Like
Replies are closed
Like
  • 1 mth agoLast active
  • 13Replies closed
  • 3771Views
  • 4 Following