Wirecast 7 Creating Numbered Folders?

Why does Wirecast create a new, empty, numerically-labeled folder every time I launch the app on my MacBook Pro running 10.12.6?

15replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • You may need to explain further. I open Wirecast 7.7 and it creates a New blank Document but it does not create any folders at all.

    Reply Like
  • Here's a screen recording.  Watch the Macintosh HD folder while opening Wirecast.

    https://www.dropbox.com/s/pgb9xf48m59sgi0/Wirecast_Problem.mov?dl=0

    Reply Like
  • Mike Verta There's nothing in Wirecast that I know of that would create that folder and we have no other reports. You may have a third party app that might be causing it when you run Wirecast.

    I'd recommend creating a New User Admin account and deleting all login items from it. Then reboot the computer and log into the new account and see if it happens. That may indicate whether it's a user or system based issue.

    Reply Like
  • Created a brand-new user Admin account and it's not happening.  Wirecast is the only app whose launch generates these folders, so how do we track down which other app/system function is being triggered by its launch?

    Reply Like
  • Mike Verta Thanks for doing that. That's an important verification.
    In the problem account look at System Preferences, Users and Groups and select the problem account and look at the Login Items. One possibility is that something running in the background is the cause. Check that and tell me what your find.
     

    Reply Like
  • In the affected account there are actually zero items in the Login Items.  I tried running Activity Monitor during launch to see if I could catch a process doing something but no luck. 

    Reply Like
  • Mike Verta said:
    I tried running Activity Monitor during launch to see if I could catch a process doing something but no luck. 

     Hmm, you're certain there's no utility running in the background? Since it's definitely account based there's something impacting the account settings that's causing it. Perhaps take a screen capture of Activity Monitor in one account vs the other when starting up Wirecast and compare just in case it's otherwise not obvious.

    Do you have any security utilities that might trigger when an app starts?

    Another experiment is do something in Wirecast (stream, record, etc) and see if something gathers in the folder.

    Reply Like
  • In returning to this issue, it eventually occurs on all accounts created on the system.  I have tried to track down any launched processes in Activity Monitor, but can't seem to catch it.  Really would like to track this down.  What should I try next?  There are no security utilities installed on the system.

     

    If it helps, when getting info on the created folders, one of the users/groups is "wheel"

    Reply Like
  • Mike Verta There's an odd system based issue going on as this isn't something Wirecast would do.
    Deactivate Wirecast.
    Uninstall Wirecast.
    Reboot the computer.
    Download and install Apple's 10.12.6 Combo Updater if you're still on Sierra.
    That could clean up potential OS issues.
    Reboot the Computer.
    Install Wirecast 7.7 again and test. 
     

    Reply Like
  • I was already on 10.12.6 so the Combo Updater wouldn't run.  I have deactivated, uninstalled, reinstalled, and reactivated Wirecast 7 and it continues to generate these folders on launch.  It is the only application which does this on the system.  Is there a way we can run a verbose debugger to find out what's being run/launched to cause this?

    Reply Like
  • Mike Verta That it initially didn't happen in the New Account but eventually the issue returned does indicate something in your system is causing it.

    You can create a support ticket and send us the system logs by going to Wirecast > Help > Send Support Information and select Create Support Ticket. Then link to your video as an example.

    The problem is since we have no other reports of this, it's something specific to your system. The cause may not be obvious to us.

    You could backup and do a fresh OS install. Granted that's a radical solution. If there's a third party utility that's causing this (or something that does a system hack) you might reintroduce it when installing such programs though.

    In any case use the Send Support Information and we'll investigate. 

    Reply Like
  • I did this but haven't heard anything.  I have since confirmed that the number on the folder is the process ID for Wirecast.  I tracked this using the "top" command in Terminal.  Every launch of Wirecast assigns it a different Process ID, and that's the number of the empty folder created.  Again, only Wirecast does this.

    Reply Like
  • Mike Verta We have no other case of this so it's something in your OS grabbing the Process ID. Wirecast doesn't create folders so it's an OS function. That the new account was OK and then starting doing it, indicates something in the OS is being triggered by some function at some point. If you didn't hear back it's likely there's nothing in the support files sent to us that indicates Wirecast itself is creating the folders. You may want to post the case number support sent you here so I can see any determination.

    Reply Like
  • Not to be contrarian, but if it's the OS generating the folders, there is nonetheless something unique about Wirecast which is prompting it. And given that no other program does this, that suggests it's not a global OS problem.  There is something very specific happening when Wirecast launches - a process, a command; something.  There must be a way to expose this, or track what's unique about Wirecast's launch - which has persisted through multiple installs.  But whether Wirecast directly creates the folders or not, its launch is what's prompting it, so it is ipso facto a Wirecast-related issue, at the least.  I understand the desire to wash one's hands of it, but perhaps we could view it as a worthy challenge instead.

    Reply Like
  • Mike Verta The OS may have grabbed a process generated by Wirecast. Using the case number, send an email back and ask the technicians to escalate.

    I could suggest a clean install of the OS but that would obviously be a radical step.

    Perhaps we can find a terminal command to stop it but that's speculative on my part. The technicians may have a suggestion for that so do ask in your follow up email

    You can try a complete uninstall of Wirecast and then reinstall.
    Disable any virus checkers you might be running or any other program that runs in the background.


    First deactivate Wirecast and write down your activation code.
    Delete Wirecast.
    Search the system (not just the user account) for Wirecast and Telestream files (I find the free EasyFind from the app store best for that) and delete them as well.
    Then boot the computer in Safe Mode

    1. Choose Apple menu > Shut Down.

    2. After your Mac shuts down, wait 10 seconds, then press the power button.

    3. Immediately after your Mac starts (some Mac computers play a startup sound), press and hold the Shift key.

    4. Release the Shift key when you see the gray Apple logo and progress indicator.

    To leave safe mode, restart your Mac again, but don’t press and hold any keys during startup.

     

    This will clean up some OS functions.
    Reboot again normally.

    Confirm there are no remaining Wirecast or Telestream files.
    Install Wirecast and test. At no point use any virus checkers or programs that run in the background.

    Reply Like
reply to topic
Like Follow
  • 6 mths agoLast active
  • 15Replies
  • 213Views
  • 2 Following