0

NDI audio issues with Wirecast 15.2 BETA

In our recent testing of 15.2 BETA, we observed that when we would bring in an NDI source from another computer running a Teams meeting on our network (same network switch) we would not get any audio from the NDI source. 

Here is our setup:

Computer 1: Running Wirecast 15.2 BETA

Computer 2: Joined a Teams Meeting and enabled Broadcast over NDI

On computer 1, in Wirecast, we see all of the video from each meeting participant in  Network Shots. We can bring in an NDI source, but were never able to see any meter movement or hear any audio from that NDI source. I was viewing this info on the source Audio panel. 

Computer 2, the audio for each participant was present in the Teams meeting and working as expected.

We also attempted to turn on NDI output in Wirecast on Computer 1, then load Wirecast on another computer on the same network and bring in that NDI feed. Again, video was good, but audio was not present.

I loaded NDI Studio Monitor to check for audio/video and both were present in NDI Studio Monitor.

After those tests, I downgraded back to  Wirecast 15.1.2 and ran the same test and all of our incoming NDI feeds had audio present.

Let me know if you have any additional questions about our setup.

19replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 wk ago
    • Reported - view

    What OS version on each computer and what version of Teams? 
    Wirecast 15.2 has an updated NDI library.
    You may want to reinstall NDI Tools on all involved computers as that's also a factor. Newtek doesn't make the version updates obvious so it's best to reinstall those and reboot the computers involved and test again.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 wk ago
    • Reported - view
    Rich Rogers said:
    I loaded NDI Studio Monitor to check for audio/video and both were present in NDI Studio Monitor.

     It's not clear what computer you were running it on. You should have this running on the Wirecast computer.
     

    In Wirecast 15.2 NDI Source Properties for your NDI shot what does it say under Status, Video, Audio?

    Like
  • We are running Windows 10 on both computers involved with Version 1.5.00.33362 of Teams on both computers. 

    I was running NDI Tools on the Wirecast computer and I have the latest version of NDI tools (I just updated it yesterday).

    I don't have any info about the NDI Source Properties at this point. I have already downgraded back to  Wirecast 15.1.2 so I can't really test at this moment. 

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 3 wk ago
      • Reported - view

      Rich Rogers Developers would like to see a copy of your logs. You can still gather them while 15.1.2 is running.

      Wirecast > Help > Send Support Information
      and then Save Report. 
      That will gather all logs including those from 15.2 when you used it so we can compare.
      You can attach the log here or send me a forum private support message system with Dropbox or Google drive link or a similar file transfer service.

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 3 wk ago
    • Reported - view
    Rich Rogers said:
    I have already downgraded back to  Wirecast 15.1.2 so I can't really test at this moment. 

     Hmm, we'd like to know if this is specific to Teams or does this happen with other NDI sources such as NDI Tools own signal generator. The main difference between 15.1.2 and 15.2 is the NDI library update.

    Thanks for reporting. We'll have to test.

    Like
    • CraigS Thanks Craig. Yes, I had noticed that the NDI library had been updated which is why I thought there might be a problem. I will update again to the BETA and run a couple more tests using other NDI sources, such as NDI test generator and let you know.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 3 wk ago
      • Reported - view

      Rich Rogers Thanks so much for doing that. We're also running our own tests.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 3 wk ago
      • Reported - view

      Rich Rogers I tested Wirecast 15.2 Beta on Windows 11 Home. On Mac computer I had NDI Test Patterns running. Wirecast 15.2 on Windows 11 had no issue seeing both audio and video from NDI Test Patterns.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 3 wk ago
      • Reported - view

      Rich Rogers Also tested on Windows 10 Home otherwise similar to above and had no issue seeing audio and video from NDI Test Patterns.

      Perhaps the issue is specific to Teams as a source.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 3 wk ago
      • Reported - view

      Rich Rogers We tested on Teams NDI out on a Windows computer to Wirecast 15.2 Beta on another Windows computer and that worked for us as well. 
      It's all working on our end. Perhaps another user can test.

      Like 1
    • CraigS OK. That's good to know. We are going to do a little more testing today and I will let you know. We are on a corporate network that is pretty tightly locked down but we do know we are working from the same network switch.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 wk ago
      • Reported - view

      Rich Rogers It's possible there's an intermittent issue. We're investigating that.

      Like
  • Like
  • It's interesting that we are having intermittent connections that work and then stop working. Even with just using NDI tools. We double checked our open ports and our network switch subnet to make sure we were actually on the same subnet and all was good there. But, we could load NDI Studio Monitor on Computer 1 then load NDI Test Patterns on Computer 2 and the signal would sometimes be present and at other times not visible. We wouldn't even see the Computer 2 NDI signal in the monitor.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 wk ago
      • Reported - view

      Rich Rogers Thanks for that. There may well be an intermittent issue. We are investigating that as well.

      Like
  • CraigS  Have you had any other bug reports on 15.2 Beta? Other than our NDI issues, we haven't seen any other notable problems. We have been hammering away at NDI with our setup here and have been seeing more consistent results. I'm not sure exactly what might have been happening earlier but other than some delay in seeing the NDI sources appear in my available network shot list, everything else seems to be working.

    Like 1
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 13 days ago
      • Reported - view

      Rich Rogers No other NDI reports at all in 15.2 (so far).

      Like 1
    • Roope Berg
    • Roope_Berg.2
    • 7 days ago
    • Reported - view

    Hi, We have not yet had time to properly test 15.2 beta, but we are using MS Teams NDI feeds heavily. Couple thinks that might help here.

    MS Teams has this "Isolated Audio" feature that is in Preview. This shows on some of our clients O365 environments and if used changes way audio is broadcasted on ndi feeds.

    Second thing to note is MS Teams NDI output is dynamic on resolution so it changes up or down depending teams meeting participant's connections.

    Then third MS Teams is outputting audio only on NDI Channel 1 and wirecast is not expanding it automatically to 1 and 2 so audio routing might be the problem or then like we discovered just with Mitti (https://imimot.com/mitti/) they needed to change the way they connected to ms teams ndi feed so audio would work ok and is now corrected on latest 2.8 version of mitti.

    What I am most expecting this 15.2 would fix is the way wirecast reads network for ndi streams earlier that has been our problem and like every third time we just can't found the teams ndi stream from wirecast but on the same machine if we run ndi tools monitor it's shown there. This is annoying problem when you are running 10-20 simultaneous remote speaker event.  

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 7 days ago
      • Reported - view

      Roope Berg Please do test 15.2 Beta as we've updated the NDI library. Keep in mind Wirecast has very flexible audio routing and the Audio Properties Channels Map function may help. 15.2 also had 4 Audio Output "buses" to send different track mixes to different outputs.

      Like
Like Follow
  • 7 days agoLast active
  • 19Replies
  • 66Views
  • 3 Following