0

NDI HX2: working on 13.1 not on Beta

Ok, I know this is kind of border testing but I have a device (Kiloview E2) that can output HX2. this device can switch between Hx1 and Hx2.

In NX2 mode (less bandwidth required for HX2) the stream show only audio in Wirecast beta, but works on 13.1 official.

The strange thing is that in OBS I have the same behavior (only sound) as in the Beta!

33replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    Do you have access to Newtek NDI HX Camera or Sienna.TV NDI Camera app?
    I believe both are using HX2

    Testing 14.0 Beta
    macOS10.14.6
    Sienna TV NDI 

    Works as expected.
     

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view

    And Newtek's App as well.

      

    Like
    • CraigS I have the same issue with Newtek HX, in fact, so is consistent with the other issue.  

      Like
  • I did more testing since I have more computers. All works both in OBS and Wirecast in other computers but this.  The only difference with this computer is that is ihe one with the beta installed. 

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi Yet it's working for me with the beta and, so far, no other reports.
      What OS and Mac model?
      Have you tried with Newtek Monitor on the problem computer?

      Since the problem computer also has the issue with OBS we need to look at what's unique about the computer.

      Try the beta on the other computers as well.
       

      Like
    • CraigS I did a lot of investigation. NDI monitor work well and can see eveything. I'm using a MacPro 6.1 with Catalina 10.15.6. I narrowed down the problem to be the NDI Runtime (libndi.4.dylib) v. 4.5.1.  I installed the old v.4.o that replaced that file in /usr/local/lib and now OBS is back to function normally like Wirecast 13.1 but not the 14b. Also NDI monitor works normally. SO i deciced to replace the libndi.4.dylib in the wirecast 14 app with the libndi.4.dylib from the 13.1 app. I have now back all the video not just the sound but the issue is that all the resolution are only 640x480 for all HX2 devices. I tried than again replaing the libndi.4.dylib in /usr/local/lib with the 4.5.1 from the other mac (Mac-mini) that is working but OBS went back to only audio, while NDI monitor is ok. So I set back libndi.4.dylib from runtime v.4 and OBS went back to work. WIth this situation I have

      NDI monitor: OK

      Wirecast 13 : OK

      OBS: OK

      Wirecast 14b: KO

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi Have you installed the current NDI Tools? Newtek sometimes updates them without notice.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi 
      BTW I see the same problem on my 2013 Mac Pro 10.15.6 with Wirecast 14.0
      but OBS works on the same system

      Wirecast 14.0 works fine on 2017 iMac Pro 10.14.6

      Like
    • CraigS Yes. I should have the most recent version. 

      Like
    • CraigS Yes. This is the same os version I have. But on the other Mac where all is working I have the same OS version. Is a really strange issue. 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi 

      Noting the following.
      2017 iMac Pro macOS 10.14.6
      /usr/local/lib libndi.4.dylib has Creation Date of March 25, 2020
      and
      /Applications/Wirecast Beta/Wirecast.app/Contents/Frameworks has Creation Date Aug 1, 2020

      2013 Mac Pro macOS 10.15.6
      /usr/local/lib libndi.4.dylib has Creation Date of 12/18/19
      and
      /Applications/Wirecast Beta/Wirecast.app/Contents/Frameworks has Creation Date Aug 1, 2020

      Please check Creation Date on your Mac Pro. 
      It's a later date on my iMac Pro macOS 10.14.6 which works

      Like
    • CraigS OK, this is a VERY interesting finding. I did all the verification as discussed: So 

      The NDI Runtime 4.5.1 (that is downloaded from OBS NDI plugin) in usr/local/lib is 

      Apr 1, 2020 - 4.1 Mb

      and this is the one creating problem  to OBS

      When I replaced this with runtime 4.0 (download from a previous version of the OBS NDI plugin):

      Oct 2, 2019 - 3.7 Mb 

      Obs went back to Normal.

      Runtime in Wirecast 13.1.3 is

      May 8, 2020 - 4,1 Mb 

      and this work for Wirecast 13.1.3 

      Runtime in Wirecast 14b is

      Aug 1, 2020

      and this do not work. 

      As mentioned I tried to copy the lib (runtime) from Wirecast 13 into 14 and I got back the video but only 640 resolution.

      Then I noticed that Newteck Video Monitor is:

      May 4, 2020 - 4,1 Mb

      So I decide to copy (replace) this both in /usr/local/lib and Wirecast 14b. Both are functioning correct as expected with this lib. They can see at any resolution the HX camera from the phone and as well the HX2 stream from the Kiloview and the HX1 from another Kiloview. For some reason I think at this point the lib included in the beta is faulty as the one in Obs runtime with this operating system, but the one of the Newtek Video monitor is perfect.

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view
    Ermanno Bonifazi said:
    the other mac (Mac-mini)

     What macOS is that running?
    In my test, the issue seems to be specific to Catalina whereas it works in Mojave for me.

    Like
    • CraigS Catalina 10.15.6

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi Try Wirecast 14 Beta on the Mac Mini to see if this is consistently a problem on Catalina (or have you tried that already and it worked?)

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi 

      Mac Pro Catalina
       

      iMac Pro Mojave which Wirecast 14 Beta works.

      Like
  • CraigS OK, this is a VERY interesting finding. I did all the verification as discussed: So 

    The NDI Runtime 4.5.1 (that is downloaded from OBS NDI plugin) in usr/local/lib is 

    Apr 1, 2020 - 4.1 Mb

    and this is the one creating problem  to OBS

    When I replaced this with runtime 4.0 (download from a previous version of the OBS NDI plugin):

    Oct 2, 2019 - 3.7 Mb 

    Obs went back to Normal.

    Runtime in Wirecast 13.1.3 is

    May 8, 2020 - 4,1 Mb 

    and this work for Wirecast 13.1.3 

    Runtime in Wirecast 14b is

    Aug 1, 2020

    and this do not work. 

    As mentioned I tried to copy the lib (runtime) from Wirecast 13 into 14 and I got back the video but only 640 resolution.

    Then I noticed that Newteck Video Monitor is:

    May 4, 2020 - 4,1 Mb

    So I decide to copy (replace) this both in /usr/local/lib and Wirecast 14bBoth are functioning correct as expected with this lib. They can see at any resolution the HX camera from the phone and as well the HX2 stream from the Kiloview and the HX1 from another Kiloview. For some reason I think at this point the lib included in the beta is faulty as the one in Obs runtime with this operating system, but the one of the Newtek Video monitor is perfect.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi Yet the lib in the Beta seems to work fine on some systems but not others.

      OBS worked for me on both my systems. I can't help but think there's another variable. We'll keep investigating.

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view
    Ermanno Bonifazi said:
    Runtime in Wirecast 14b is
    Aug 1, 2020
    and this do not work. 

     Works for me on my Mojave system but not on my Catalina system which is 2013 Mac Pro like yours.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 2 yrs ago
    • Reported - view
    Ermanno Bonifazi said:
    For some reason I think at this point the lib included in the beta is faulty as the one in Obs runtime with this operating system

     Perhaps it's a combination of the two having an impact on both. We'll investigate the Newtek NDI Lib considering that neither OBS or Wirecast is uses that.

    Like
    • CraigS I don't think they conflict between them. OBS use the runtime in use/local/lib while Wirecast have its one in the Framework directory. I think is an issue with v 4.5 of the lib of some specific date in Catalina. In fact as I said replacing the usr/lib with the 2020 version from NDI Monitor bring back OBS to work fine, and as well replacing with this same lib the one in Wirecast - framework bring Wirecast back to full function too. 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi Developers think there may be something else relating to the NDI Lib at issue. If it were that simple than neither OBS or Wirecast would break following Newtek's development instructions.

      Like
    • CraigS I don't know what they mean but this is the reality demonstrated by facts, both previous and later version than 4.5 works and not that release currently distributed by OBS ndi 4.9 and Wirecast beta 14. The fact is Newteck video monitor never had problem in any situation and  replacing the faulty lib with previous and same version as Newtek Monitor make the other programs works too. The  facts that also you have one working and one not confirm that something is broken and beta is still on a small scale deployment...

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 2 yrs ago
      • Reported - view

      Ermanno Bonifazi But there does seem to be discrepancies in my experience.
      On my 10.15.6 2013 Mac Pro while Beta 14 did not work OBS worked for me but did not work for you. On 10.14.6 2017 iMac Pro Beta 14 does work. The Beta 14 worked for you on your Mac Mini? There may be another variable. Since OBS failed for you and worked for me on the Mac Pro there's something else it seems.

      Like
Like
  • 2 yrs agoLast active
  • 33Replies closed
  • 147Views
  • 3 Following