0

Unable to stream 1080p on Facebook Live despite the correct settings

There is no way I can stream at 1080p on Facebook Live despite the settings being all correct.
I set the canvas size to 1080p, when I open the encoder settings it tells me there are no outputs compatible with that size and asks me if I want to fit the area.
I insist on selecting 1080p but the resulting output on Facebook is always 720p.
What am I doing wrong?

I'm on Wirecast 14.1.2 but I also tried 14.2.1, on Apple Macbook M1

19replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Facebook controls which accounts can stream 1080 and currently I don't think they allow any regular users that access. 

    Like
  • I also thought it could depend on that, but trying with another encoder, with the exact same account and on the same page I can stream at 1080p without problems ...

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Toto Please verify that Facebook is actually showing a 1080 stream. Please list the encoder as well.

      I believe only Gaming Video Creator Pages participating in their Level Up program have access to 1080 streaming. 

      Like
  • Yes I'm sure. On the same account, if I use a different encoder I can stream at 1080p (see screenshot), even the downloaded file is actually 1080p.

    If, on the other hand, I use Wirecast, I don't go beyond 720p despite regularly transmitting at 1080.

    I also tried to push always on Facebook in rtmps and in the Creator Studio I receive a stream at 1080 but it warns me that the resolution is too high, so then it publishes at 720p.

    I don't understand why Facebook applies this restriction only on Wirecast streams and not on the other encoders, it's really strange ...

    Like
  • Toto said:
    if I use a different encoder

     What encoder?

    Like
  • In this test I used Mimolive, with normal settings for Facebook

    Like
  • On Wirecast I used all the settings for Facebook, I tried 30p, 60p, always 1080p and always I have a 720p as result, on Facebook player.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Toto Thanks for that information.
      Can you please list the exact settings used in Mimolive encoder? You can include a screenshot if that helps.
      Then try matching the same settings in Wirecast.

      Investigating WIRE-18950

      Like
      • Toto
      • Toto
      • 11 mths ago
      • Reported - view

      CraigS here's the screenshot of default settings of Mimolive (that correctly stream at 1080p).
      I tried to replicate the same settings on Wirecast, but it still stream at 720p as result.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Toto That match settings may not be obvious.
      H.264 could be x264, MainConcept H.264, Apple H.264
      Profile Level "Auto" could be High, Main, Baseline.
      If it were x264 there would be a Quality setting and possibly a command-line option.
      Audio doesn't include mono, stereo or sample rate.
      Keyframe level is measured in seconds so that would depend on the frame rate also not mentioned.

      Do you know you've matched those settings without trying many variables? At the very least it doesn't look like x264 which is what Wirecast defaults to. 

      What settings did you try specifically in Wirecast?
      I would recommend testing MainConcept H.264 and Profile Baseline (then try Main and then High).

      Like
      • Toto
      • Toto
      • 11 mths ago
      • Reported - view

      CraigS I've tried all the combinations you're talking about in Wirecast, except for the control line, with no results. I clearly adapted the whole thing to the bits of the project, trying to get presets as close as Mimolive.

      It is quite clear to me that the problem is in Wirecast, if there are default presets to go live to 1080p live and does not work, the problem is there, not the fact that user can’t adapt them to those operating in another software.

      Like
  • Toto said:
    if there are default presets to go live to 1080p live and does not work, the problem is there,

     

    Toto said:
    I've tried all the combinations you're talking about in Wirecast,

     This seems to conflict with the above. If the presets were the issue then a custom setting matching Mimolive would be the solution. Since the codecs are "universal" (certainly not exclusive to Wirecast) then it may not be about the settings at all. 

    x264, MainConcept, Apple H.264 all come from other developers with "hooks" available to all third-party developers to implement. Perhaps MimoLive's H.264 is from another source as they don't mention it.

    Like
      • Toto
      • Toto
      • 11 mths ago
      • Reported - view

      CraigS you suggested me that preset could be the issue, I only tried what you suggested. Please, follow me:

      I have the same account Facebook, the same source, the same project settings (1080p, 30fps): with default 1080p preset for Facebook on Mimolive I can stream effectively at 1080p, and Facebook player show me 1080p.
      With default 1080p preset on Wirecast I stream effectively at 720p, as result on Facebook player.
      I tried several changes in Wirecast preset according to settings of Mimolive but no result.

      These are the facts.

      There aren't limitation on my account, if the issue is on the settings I don't know... but it's clear that the issue is in Wirecast, are you agree?

      Like
  • Toto said:
    it's clear that the issue is in Wirecast, are you agree?

     Yes but not the settings. So we need to investigate what else may be the cause.

    Like
      • Toto
      • Toto
      • 11 mths ago
      • Reported - view

      CraigS ok, i made all test on a new Macbook Pro M1.
      Next test I'm going to do is try the same situation on a Windows machine.

      I'll update you.

      Like
  • Same situation.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Toto We're contacting Facebook on this because even if it were a settings issue, your testing would have hit a working combination so we think it may be something else. Wirecast had been approved by Facebook for 1080 use but perhaps they changed something we need to be aware of.

      Like
      • Toto
      • Toto
      • 11 mths ago
      • Reported - view

      CraigS thank you!!!

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      Toto 👍

      Like
Like Follow
  • 11 mths agoLast active
  • 19Replies
  • 42Views
  • 2 Following