2

Screenflow 10 wont record from camera

Downloaded the new screenflow the other day and first time using it won't record from any camera (webcam nor capture card camera)

 

I have all permissions correct (even screenflow helper). Double checked in 

Screenflow recognizes the camera, image is there in the preview. But nothing gets recorded and the recording from the camera doesn't show up in the editor.

M1 mac mini, latest Big Sur

Tested it on Screenflow 9 and that still works. This is frustrating because the 9-version couldn't render colors correctly when exporting and now the camera doesn't work in v-10....

87replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • C Hunter
    • C_Hunter
    • 1 yr ago
    • Reported - view

    CraigS

    To clarify...

    1. I was finally able to get the "Enable Camera" option to take.

    2. In System Prefs >....Privacy > Camera. SF 10.0.3 does not show up. SF 9.0.3 does.

    3. in System Prefs >....Privacy > Screen Recording > both apps show up there.

    4. In SF 9.0.3, I can select my external camera, not so in SF 10.0.3

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      C Hunter Uninstall ScreenFlow 10.0.3 (toss app in trash and delete) and then reinstall it again and try enabling it from 10.0.3 again.

      Like
    • C Hunter
    • C_Hunter
    • 1 yr ago
    • Reported - view

    Well, that was an interesting experience.

    I did toss SF 10.0.3 in the trash and deleted trash. Then I downloaded SF 10.0.3 from Telestream site. Double-clicking on download, I was greeted with a message that SF 10.0.3 would be installed and would move 9.0.3 into the same folder. What really happened was, 10.0.3 did an overwrite of 9.0.3 and 9.0.3 disappeared everywhere on my system that it was recognized, including System Prefs. @#^$^.  Thank goodness for my hourly TimeMachine backup. And, SF 10.0.3 still does not recognize my external camera. My fresh copy of SF 9.0.3 does. ;-)

    Like
    • C Hunter
    • C_Hunter
    • 1 yr ago
    • Reported - view

    CraigS

    SF 10.0.3 is now showing in System Prefs...Camera, but still can't be selected in the SF 10.0.3 app.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      C Hunter Reboot the computer. That often has to be done for the setting to take.

      Like
    • C Hunter
    • C_Hunter
    • 1 yr ago
    • Reported - view

    Way ahead of you. Did that, too! Still no joy!

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      C Hunter If it's specific to that camera perhaps there's an incompatibility.
      I believe the Canon GL-2 is a very old DV Camera released 20 years ago so it may not be compatible depending on what we've changed.
      Do not connect the camera through the dock.
      Attach directly through the capture device.
      What capture device are you using?
      Please check the camera in Quicktime to see if it works there.

      Like
    • C Hunter
    • C_Hunter
    • 1 yr ago
    • Reported - view

    CraigS The camera works with Quicktime, Zoom, Adobe Premiere, SF 9.0.3, etc. Not SF 10.0.3. Have to connect the camera through the dock, no other method to connect.

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view
    C Hunter said:
    Have to connect the camera through the dock, no other method to connect.

     How are you connecting it given DV is Firewire. If you're using an analog out that would need a video capture device. Does Dock have Firewire input? What dock is it specifically and what model Mac and what macOS?

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view
    C Hunter said:
    What really happened was, 10.0.3 did an overwrite of 9.0.3 and 9.0.3 disappeared everywhere on my system that it

     What I do is manually put the previous version in a folder in Applications before installing the new version.

    BTW we keep previous versions of ScreenFlow at this link under Previous Versions all the way back to version 5.

    Like
    • C Hunter
    • C_Hunter
    • 1 yr ago
    • Reported - view

    CraigS

    MacBookPro14,3

    OWC Thunderbolt 3 Dock, dock has Firewire input.

    Like
    • C Hunter
    • C_Hunter
    • 1 yr ago
    • Reported - view
    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      C Hunter Thanks for that info.
      That's one of their discontinued docks. I have a newer version sans Firewire port.

      Given that DV cameras are long gone from most production we may have stopped testing for support and compatibility. I'll see what the developers say.

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      C Hunter Are you on Catalina or Big Sur?

      Like
    • C Hunter
    • C_Hunter
    • 1 yr ago
    • Reported - view

    Catalina 10.15.7

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      C Hunter thanks. Investigating FLOW-11288

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      C Hunter For various reasons the developers no longer want to support the DV codec so you'll have to stick with 9 to use that camera. Sorry.

      Like
    • ishu verma
    • ishu_verma
    • 11 mths ago
    • Reported - view

    I'm having the same issue as described above (no recording from camera) on the MacBook Pro M1 with Screenflow 10.0.3. The privacy settings have enabled Screenflow to use the inbuilt camera, the preview shows up for FaceTime HD camera but when I record, only the audio file shows up.
    Considering lack of any resolution above, this issue is still open and affecting the inbuilt camera for MacBook Pro. I specifically bought this version of ScreenFlow as it's supposed to fully support M1 chip but looks like its broken

    Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 11 mths ago
    • Reported - view
    ishu verma said:
    he privacy settings have enabled Screenflow to use the inbuilt camera, the preview shows up for FaceTime HD camera but when I record, only the audio file shows up.

     That's not the same issue since the others involved external cameras. ScreenFlow certainly does capture the FacetimHD Camera so perhaps there's an issue with your system. Please make sure you've updated the OS to 11.6.2 or 12.1 and then reboot the computer.

    Like
    • ishu verma
    • ishu_verma
    • 11 mths ago
    • Reported - view

    craigs I was using 12.0.1 version and per your suggestion have now updated to 12.1. I'm now able to record using the FaceTime camera. Thanks.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 11 mths ago
      • Reported - view

      ishu verma Good to hear. 👍

      Like
    • John Noble
    • John_Noble
    • 10 mths ago
    • Reported - view

    Just want to add a +1 to this thread.

    My setup:

    • MacBook Pro M1 14"
    • Monterey 12.1
    • ScreenFlow 10.0.3

    I'm trying to record from my iPhone (13) via EpocCam (all latest versions). The phone is tethered with a USB-C/Lightning cable directly to the Mac, and shows up in the preview and in the recording monitor. But when the recording is completed, no video appears.

    All permissions are confirmed, and I've rebooted.

    Update: ScreenFlow 9 doesn't work either. 😐

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 10 mths ago
      • Reported - view

      John Noble Epoccam is not yet tested compatible. Sorry about that. FLOW-7901

      Like
      • John Noble
      • John_Noble
      • 10 mths ago
      • Reported - view

      CraigS Thanks for the information. Typical, I just sold my old Intel MBP last night! Should have held on to it...

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 10 mths ago
      • Reported - view

      John Noble Reincubate seems to work more reliably for us that EpocCam

      Like
      • John Noble
      • John_Noble
      • 10 mths ago
      • Reported - view

      CraigS Appreciate it, will check it out later today and report back.

      Like
Like2 Follow
  • 2 Likes
  • 1 mth agoLast active
  • 87Replies
  • 582Views
  • 17 Following