1

USB camera recording issues

Screenflow 10 records mac's built-in camera properly.

However, when I plug in my SONY alpha 5100 through an usb capture card, it takes the 16:9 video and stretches it to 4:3. It's annoying. Screenflow 9 recorded that same camera on the same computer properly.

Interestingly, when setting up the recording and rendering the preview of the camera image, it's shown in 16:9 ratio. But in the recording monitor and the recording itself, it's stretched to 4:3.

Best,
Mat

71replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view
    Blaine Hoffmann said:
    EsthePro 1080p web camer

     

    Blaine Hoffmann said:
    connected via Apple USB dongle to USB-c.

     How does it look in Quicktime Movie Recording?

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Blaine Hoffmann Just testing so far. Hope to have it ready soon.

      Like 1
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Blaine Hoffmann Mat Milbury Please check and respond to forum private message.

      Like 2
      • Blaine Hoffmann
      • The SafetyPro Podcast
      • Blaine_Hoffmann
      • 1 yr ago
      • Reported - view

      CraigS test 9 confirmed working

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Blaine Hoffmann 👍

      Like
  • Having the same problem here. Using a camera with a HDMI to USB Capture Card (from Sandberg). I can confirm it is a problem with Screenflow 10 (or 10.0.2). Had to record a video today and luckily I had the option to record it with an older version of Screenflow with which it worked just fine. Have tried different video sizes and discarding and choosing the camera again but nothing seems to get it working.

    Hope it's gonna get fixed soon :)

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Fabio Ambrosi Given the feedback we're getting from testers it should be soon.

      Like 1
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      Fabio Ambrosi See forum private message.

      Like
  • Here also same problem with the BlackMagic Atem Mini.

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 1 yr ago
      • Reported - view

      René Fürst See forum private message.

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 1 yr ago
    • Reported - view

    ScreenFlow 10.0.3 has just been released. Please install reboot and test.

    Like
  • Hi there! I'm having the same exact problem. I'm currently using Screenflow 10.0.5.

    The metadata says the resolution is 1600x1200. But the settings when I'm recording are for 1080 and it doesn't look distorted when I look at a preview of the USB video before recording.

    I'm wondering both how to fix the problem before recording and also wondering if anything can be done about the videos I've already recorded. Thanks!

    Best wishes,

    Mel

    Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 4 mths ago
      • Reported - view

      Mel Hopper Koppelman maybe not the same issue as it was fixed in 10.0.3 and no reports on this thread until yours.

      Mel Hopper Koppelman said:
      The metadata says the resolution is 1600x1200. But the settings when I'm recording are for 1080 and it doesn't look distorted when I look at a preview of the USB video before recording.

      We're going to need details and screenshots such that we can reproduce the issue.
      Camera and settings, capture device, Configure Recording setting, Metadata showing the size. It's possible there's an issue with the capture device.

      Like
    • CraigS Thanks, the reason why it seemed like a similar issue is because the problem only started a week ago and I didn't change my hardware. It's also not happening when I use eCamm, which is my current work around. But I do have some videos that I already recorded that before I saw the problem and I want to know if I can salvage them by adjusting the settings. 

      I'm using an iPhone Xs as a USB capture device and a cheapy capture card off of Amazon. I'll send screen shots of the configure recording settings tomorrow. Thanks!

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 4 mths ago
    • Reported - view
    Mel Hopper Koppelman said:
    the problem only started a week ago and I didn't change my hardware.

     What changed? 
    ScreenFlow 10.0.5 was released two months ago.

    Mel Hopper Koppelman said:
    I'm using an iPhone Xs as a USB capture device and a cheapy capture card off of Amazon.

     I have one of those $10-$15 ones to test with. The hardware in those may get updated periodically though. I can test with an iPhone 12. If you're going through a USB Dock or Hub that may impact the results.

    Like
    • CraigS Thanks, I think I did only update to the latest version recently. I usually wait a little bit so bugs can get worked out. 

      I am going through a Hub. But again, that part of the set up hasn't changed.

      Thanks!

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 4 mths ago
      • Reported - view

      Mel Hopper Koppelman  Please do test without the hub.
      What macOS?
      What Mac model including CPU type?
      What are the specs of your USB capture device (can you link to it on Amazon for example)?

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 4 mths ago
      • Reported - view

      Mel Hopper Koppelman Matthew Donnachie 
      iPhone 12Pro iOS 15.4.1 Lighting to USB into USB hub and it shows as 1170x2532 on iMac Pro ScreenFlow 10.0.5 macOS 11.6.5. Since the iPhone doesn't have HDMI out I'm not sure what the purpose is for an HDMI to USB video capture device. 

      Like
    • CraigS Thanks, I'll do the test and send through the results tomorrow.

      MacOS: 12.3.1

      Model: MacBook Pro with M1

      USB capture card: https://www.amazon.com/gp/product/B088HBRM7T/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

      "Since the iPhone doesn't have HDMI out I'm not sure what the purpose is for an HDMI to USB video capture device." It allows me to send a clean feed from FILMICpro to my computer

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 4 mths ago
    • Reported - view
    Mel Hopper Koppelman said:
    HDMI to USB video capture device." It allows me to send a clean feed from FILMICpro to my computer

    Since the phone doesn't have HDMI out I'm not sure how that helps.

    Wouldn't it make more sense to try something like Camo Studio which will give you a clean feed out of the iPhone camera?
     

    Like
    • CraigS I am using an iPhone to HDMI adapter: https://www.amazon.com/Apple-Lightning-Digital-AV-Adapter/dp/B009WHV3BM/ref=sr_1_3?keywords=iphone+to+hdmi&qid=1651745811&sr=8-3

      "Wouldn't it make more sense to try something like Camo Studio which will give you a clean feed out of the iPhone camera?"

      I'm not sure if this would make more sense. My current set up worked perfectly until a couple of weeks ago and still works on Ecamm Live. FILMICpro gives me a lot of control over the settings. 

      Like
    • CraigS Ok, new set up, completely different problem.

      I downloaded Camo (which is really cool, thank you!) and did away with 4 pieces of hardware. My phone is connected to my MacBook Pro (I still need to use a hub to connect my microphone).

      All looked good but in editing, the video recording from Camo seems to be *faster* than the audio. I did a clap at the beginning to sync audio to video. But the video is racing ahead.

      Since I've only been using Camo for about 20 minutes, I'm a bit at a loss as to where to begin troubleshooting. I'm not sure if I should be contacting them or Screenflow for help here.

      Thanks!

      Like
    • Mel Hopper Koppelman I have put in a support request to Camo as well. 

      Like
      • CraigSModerator
      • Telestream Desktop Forum Moderator
      • CraigS
      • 4 mths ago
      • Reported - view

      Mel Hopper Koppelman Camo works well through hubs in my testing. Though it does give you a warning if you're using one. One thing to check is to see if any sync difference is sample rate-related. Make sure the audio is 48kHz.

       

      Like
    • CraigS Thanks, CraigS. What app is that screenshot of? 

      I had it set up so that I wasn't using Camo for audio, the audio was coming from my USB mic. 

      While I sort out how to set this up for future recording, is there anything I can do to be able to use my current recordings? Is there a way to slow down the video so that it'll sync up to the audio in Screenflow?

      Thank you!

      Like
    • CraigSModerator
    • Telestream Desktop Forum Moderator
    • CraigS
    • 4 mths ago
    • Reported - view
    Mel Hopper Koppelman said:
    I am using an iPhone to HDMI adapter:

     My hunch is that's your issue. I'm not sure that will work as you intend it with current macOS on M1 hardware. It's not something we'd test.

    You should test phone lighting to USB into Mac.
    I have the exact same HDMI to USB adaptor as you and can confirm that would work too. I'd avoid the dock (as it can impact resolution) and use a direct USB-A to USB-C adaptor.

     

    Mel Hopper Koppelman said:
    My current set up worked perfectly until a couple of weeks ago and still works on Ecamm Live.

    It may work with our Wirecast as well which is the equivalent of ECAMM Live.
    ScreenFlow is a different type of program. You'd have to test in Quicktime.

    Like
Like1 Follow
  • 1 Likes
  • 4 mths agoLast active
  • 71Replies
  • 150Views
  • 8 Following