0

Captured DV in QT Wrapper to ProRes Always Fails

I have two iMacs running different versions of the MacOS, each with a different version of Episode:

iMac from 2011
Max OSX 10.6.8 (Snow Leopard)
Episode Version 6.3.1.23

iMac from 2017:
MacOS 10.13.6 (High Sierra)
Episode Version 7.4.0.7858 (7858)

I am starting with: Quicktime Movie file with DV-NTSC video created via export from Final Cut Express HD 3.5.1 (a pared down version of Final Cut Pro 7) on the older iMac, with the following characteristics per MediaInfo. It is captured video from a miniDV tape:

General
Complete name: /Users/my user name here/Desktop/name of video file here.mov
Format: MPEG-4
Commercial name: DVCPRO
Format profile: QuickTime
Codec ID: qt   2005.03 (qt  )
File size: 7.20 GiB
Duration: 34mn 1s
Overall bit rate: 30.3 Mbps
Recorded date: 2000-01-22 21:13:44.000
Encoded date: UTC 2019-09-07 19:07:06
Tagged date: UTC 2019-09-07 19:13:38
Writing library: Apple QuickTime

Video
ID: 1
Format: DV
Commercial name: DVCPRO
Codec ID: dvc 
Duration: 34mn 1s
Bit rate mode: Constant
Bit rate: 24.4 Mbps
Encoded bit rate: 28.8 Mbps
Width: 720 pixels
Clean aperture width: 704 pixels
Height: 480 pixels
Clean aperture height: 480 pixels
Display aspect ratio: 4:3
Original display aspect ratio: 4:3
Clean aperture display aspect ratio: 4:3
Frame rate mode: Constant
Frame rate: 29.970 (29970/1000) fps
Standard: NTSC
Color space: YUV
Chroma subsampling: 4:1:1
Bit depth: 8 bits
Scan type: Interlaced
Scan type, store method: Interleaved fields
Scan order: Bottom Field First
Compression mode: Lossy
Bits/(Pixel*Frame): 2.357
Time code of first frame: 00:00:00;03
Time code source: Subcode time code
Stream size: 5.80 GiB (81%)
Encoded stream size: 6.84 GiB (95%)
Encoding settings: ae mode=full automatic / wb mode=automatic / white balance= / fcm=manual focus
Language: English
Encoded date: UTC 2019-09-07 19:07:06
Tagged date: UTC 2019-09-07 19:13:38
Color primaries: BT.601 NTSC
Transfer characteristics: BT.709
Matrix coefficients: BT.601

Audio #1
ID: 2
Format: PCM
Format settings: Little / Signed
Codec ID: sowt
Duration: 34mn 1s
Bit rate mode: Constant
Bit rate: 1 536 Kbps
Channel(s): 2 channels
Channel layout: L R
Sampling rate: 48.0 KHz
Bit depth: 16 bits
Stream size: 374 MiB (5%)
Language: English
Encoded date: UTC 2019-09-07 19:07:06
Tagged date: UTC 2019-09-07 19:13:38

Audio #2
ID: 1-0
Format: PCM
Format settings: Big / Signed
Muxing mode: DV
Muxing mode, more info: Muxed in Video #1
Duration: 34mn 1s
Bit rate mode: Constant
Bit rate: 768 Kbps
Encoded bit rate: 0 bps
Channel(s): 2 channels
Sampling rate: 32.0 KHz
Bit depth: 12 bits
Delay relative to video: 100ms
Stream size: 187 MiB (3%)
Encoded stream size: 0.00 Byte (0%)

Audio #3
ID: 1-1
Format: PCM
Format settings: Big / Signed
Muxing mode: DV
Muxing mode, more info: Muxed in Video #1
Duration: 34mn 1s
Bit rate mode: Constant
Bit rate: 768 Kbps
Encoded bit rate: 0 bps
Channel(s): 2 channels
Sampling rate: 32.0 KHz
Bit depth: 12 bits
Delay relative to video: 100ms
Stream size: 187 MiB (3%)
Encoded stream size: 0.00 Byte (0%)

Other
ID: 3
Type: Time code
Format: QuickTime TC
Duration: 34mn 1s
Frame rate: 29.970 (29970/1000) fps
Time code of first frame: 00:00:00;00
Time code, striped: Yes
Language: English
Encoded date: UTC 2019-09-07 19:13:38
Tagged date: UTC 2019-09-07 19:13:38

I am trying to create a ProRes file from this video with the following settings, and similar settings that I've also tried:

Container: MOV

Video Codec: ProRes

ProRes version: ProRes 422 (HQ)

Audio Codec: Pass Through

File Extension: mov

Video Filter:
De-interlace, Double Frame Rate (something I especially like about Episode's features)

Video Filter:
Resize, Image Size: VGA 640x480
Initial Crop, Left: 8 Pixels, Right: 8 Pixels
Maintain Proportion Width: None (Distort)

Both versions of Episode always fail at this. I can't figure out what I am doing wrong.
 

17replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • As a test please use our ProRes 422 NTSC preset unaltered.
    As a second test please use H264 MP4 1Mbps preset unaltered.

    Reply Like
  • CraigS Done. Both tests were successful. Does this suggest the problem has something to do with my settings for the Quicktime wrapper?

    Reply Like
  • John Alexander Mozzer It may be a settings issue relative to the source. Try duplicating the present and changing one setting that you'd like and see if that causes failure. You may find a specific setting is at issue.

    Reply Like 1
  • CraigS 

    System Encoder copies with changes, tested as follows one at time, always starting over with a fresh copy of the System Encoder:

     

    ProRes 422HQ NTSC Copy-Frame Rate off -SUCCESS

    ProRes 422HQ NTSC Copy-Frame Rate off-My Deinterlace Settings on-FAILED

    ProRes 422HQ NTSC Copy-Frame Rate changed-My Deinterlace Settings on-FAILED

    ProRes 422HQ NTSC Copy-My Deinterlace Settings on-FAILED

    ProRes 422HQ NTSC Copy-Frame Rate off-My Deinterlace Settings on-Audio Speed half-FAILED

    ProRes 422HQ NTSC Copy-Audio Changed to Pass Through-SUCCESS

    ProRes 422HQ NTSC Copy-Resize Changed to My Resize settings-SUCCESS

     

    My User Encoder for H.264 was a success, so I didn’t otherwise test it. Note that my de-interlace settings (doubling frame rate to 59.94fps) are successful when encoding to H.264.

     

    Not sure what to make of these results.

    Reply Like
  • John Alexander Mozzer So it seems you may need to look further at variations at deinterlacing.

    Keep in mind Episode is no longer supported but deinterlacing generally worked with proper settings. The last version of Episode was 7.5 which is still available for download if you want to try that. 

    Reply Like
  • CraigS Yes, I am aware that Episode is no longer supported, and am grateful to find some support on this forum.

    Reply Like
  • John Alexander Mozzer Try 7.5.
    Note that the MP4 preset i had you test had Deinterlace enabled and that worked.

    Reply Like
  • CraigS Yes, but I like to double the frame rate, and my own user encoder for H264, with Double Frame Rate checked, also worked. It's the biggest reason that I like using Episode for de-interlacing, because no other program that I know of provides this feature (though I will look into Switch.). I think it's really the only way to de-interlace without losing information.

    Reply Like
  • John Alexander Mozzer said:
    Yes, but I like to double the frame rate, and my own user encoder for H264, with Double Frame Rate checked,

     Can you test with a different source using ProRes and your preferred Deinterlace setting?

    Reply Like
  • CraigS I already know, it's worked starting with ProRes with interlaced video, going from 720x480, interlaced, 29.97fps to 640x480, progressive, 59.94fps.

    Reply Like
  • John Alexander Mozzer So it's something about the DV .MOV and deinterlacng while encoding to ProRes.

    Reply Like
  • CraigS What does "will not run, required a different status of prior task" imply?

    Reply Like
  • John Alexander Mozzer If memory serves me, that means a preceding setting conflicts. Episode has an order of operation on filters in which the end results of one process impacts the next. 

    It may mean some other filter setting is at issue (conflicting) with the deinterlace setting you're using.

    Reply Like
  • CraigS 

    The source video is from a MiniDV videotape captured over Firewire. I had a new theory, which I thought was viable, but test results only add to the mystery. I thought the problem might be three things in combination: 1.) the original MiniDV videotape consisting of 12-bit rather than purely 16-bit audio, 2.) doubling the frame rate during de-interlacing, 3.) setting audio to Pass Through. 

    First, I tested my user encoder on two other MiniDV videotape capture files, with purely 16-bit audio. Tests failed with Episode Version 6.3.1.23 on the old iMac, were wonderfully successful with Episode Version 7.4.0.7858 on my new iMac. The latter produced the desired ProRes 422HQ, 640x480, 59.94fps video.

    Then, I tested the source video (the subject of this post) with my user encoder, except audio set to AAC and PCM rather than Pass Through, with Episode Version 7.4.0.785. Both failed.

    Reply Like
  • CraigS Re: Try 7.5. Do I have to uninstall 7.4 first?

    Reply Like
  • John Alexander Mozzer You should be able to install over 7.4. Keep the old installer just in case but 7.5 fixed a last round of bugs so it should be the best one to use generally. 

    Reply Like
  • One thought may be to go the intermediary route and transcode it to an interlaced ProRes file and then transcode that file. That's been a workaround for order of event operation issues. I remember way back when there were suggestions that we allow users to change the order of events but that didn't happen with Episode. Probably a Vantage feature though.

    Reply Like
Like Follow
  • 2 mths agoLast active
  • 17Replies
  • 19Views
  • 2 Following