mac os update -> screenflow 4.5 does not work any more

i

i moved from X.10.10 to X.10.12 (sierra) for professional compatibility wth a software i need

then my screenflow 4.5 does not work any longer

i can not afford the price of screenflow 8 on the appstore

is there a legal way to get screenflow 5 or 6 for mac os Sierra ?

i need it for secondary professional purpose

thanks

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • ScreenFlow 4.5.x OS compatibility ended officially with Yosemite 10.10.x. 
    Never update an OS if you can't update programs for compatibility.
    ScreenFlow 8.x is compatible with Sierra 10.12.x.

    You can buy ScreenFlow 8 from us directly at a limited time 30% discount

    The only legal way is to upgrade or purchase. Only ScreenFlow 8 is available for sale.

    Reply Like
  • thanks for the answer

    ok..

    i was obliged to get in your commercial logic, so i upgraded 4.5 to 8 for ~50€

    Reply Like
  • Vincent Douce You're welcome of course and thanks for upgrading.

    Reply Like
reply to topic
Like Follow
  • 3 wk agoLast active
  • 3Replies
  • 66Views
  • 3 Following