9.0(34022) | April 4th 2018 | Second 9.0 Beta Build

The Wirecast team is pleased to announce a new beta version, Wirecast 9.0 Beta 2! We would appreciate any feedback – positive or negative – that you may have. In this version we've teamed up with P.I. Engineering to add support for a new USB controller, XKeys 128. This controller includes direct selection of 12 sources on five layers, transition controls and much, much more. Additional information on this controller can be found on their website

 

PDF version of these release notes can be found here.

9.0 BETA2 – New Features

NEW –  XKeys 128 Support

  • Full control of layers, sources and transitions
  • Audio Mixer and Audio Preview controls
  • Start and Stop Wirecast outputs
  • Replay Controls

9.0 BETA2 – Improvements

  • Improvement - Allow 'Enter' key to add shot in add source UI
  • Improvement – Lower default keyframe interval to 2 seconds

9.0 BETA2 – Fixes

  • Fixed - Fixed Rendezvous sources not pulling video correctly in Windows 7
  • Fixed - Web Stream and Screen Capture sources enumerating twice in the source selection window
  • Fixed - Immediate A/V sync issue streaming to Facebook if started after another output
  • Fixed - Indefinite hang when sending two shots live then opening a playlist
  • Fixed - After 20 encodes all outputs would fail to encode on macOS

9.0 BETA2 – Installers

macOS

Windows

33replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Please post beta feedback to this section of the forum!

    Like
  • When will the full (non Beta) version of wirecast 9.0 be released? 

    Like
  • Raff Agostino after beta testing reveals any more issues we may need to address and those issues are fixed. Beta determines needs.

    Like
  • CraigS - How stable is Beta? As you can imagine. I don't want it going down during one of our 6hour live stream events. So how is it performing? 

    Like
  • Raff Agostino Generally I wouldn't consider a beta for mission critical work as there may be unanticipated issues. Of course for non mission critical work, that would be ideal to test and determine possible issues.

    Like
  • when will version 9.0 be out of BETA and a fully tested version be made available?

    Like
  • I didn't expect Wirecast 9.x to overwrite Wirecast 8.x.  I indicated during install that I wanted the install to occur in a folder called Wirecast 9, which it did.  However, it appears Wirecast 8.3 is no longer on my system.  I have a show coming up in a week and hesitate using a beta.  Please advise.  Thank you.

    Like 1
  • Hi Scott . Just download 8.x again. After you have placed 8.x into your applications folder, choose to keep both copies. Any Wirecast layouts that you've created prior to the recent removal of 8.x should still be on your system. Now when you open up Wirecast 8.x you will have open by the file name you created for your layouts.

    I hope this helps. 

    Like
  • Bobby D Live said:
    when will version 9.0 be out of BETA and a fully tested version be made available?

    That of course would depend on how much more tweaking we need to do. We do have target dates but they have to be flexible given the very nature and purpose of releasing a beta.

    Like
  • CraigS Hi Craig.. any hints re: target dates? I'm asking because I have projects to be launched and I' don't want to webcast with version 8.3. Just too many glitches.

    Is there a potential to have access to 9.0 in April sometime? Or ONLY May?

    Like
  • Version Beta 9.2 is not playing well with my camera names.  Maybe it is user error, but I can't figure it out.

    Like
  • talrmde 8.3 simply installed on top of the 9.x Beta.  It doesn't seem to matter what I name the folder during install.

    Like
  • Scott Newman On Mac I create a folder and drag it into the folder from the installer window.

    Like
  • Bobby D Live said:
    Is there a potential to have access to 9.0 in April sometime? Or ONLY May?

    Unfortunately I can't say as the powers that be having posted anything at NAB regarding dates. Check Telestream Wirecast on Facebook to see if they drop hints.

    Like
  • CraigS thanks!

    Like
  • Bobby D Live You're welcome. Our Telestream Wirecast Facebook link if others are interested in following.

    Like
  • I noticed that wirecast application does not save frame rate. Even if you do the following operation frame rate will not be saved.(return to default 30fps)

    Not only Frame Rate but also other preferences such as diagnostic and usage settings are not saved too

    1) File-->Preference
    2) Performance
    3) Change video frame rate to 60
    4) close preference window
    5) File--> Save(Ctrl + S)
    6) Close wirecast
    7) Re-open wirecast
    8) Frame rate setting return to 30

    Operating System: Windows 10(Japanese)

    I have to change the frame rate every time I open a wirecast. How can I solve this problem?
     

    Thank you for your cooperations

    Like
  • Kimihiko Yano

    Does the user account have Administrator permissions?

    You should also make sure that you have Read and Write permissions for the Preferences file as well as the parent directory. The Preference file is stored here: C:\Users\<YOUR USER ACCOUNT>\AppData\Roaming\Wirecast\net.telestream.wirecast.xml

    Like
  • Scott Newman 

    The names in the shot bin are "shot" names, and the names in the Add Source menu are "source" names. If you rename the shot, that is what the display name will be in the shot bin.

    Like
  • Rory Maloney 

    Thank you for your advice

    1) My account has administrator privileges

    2) Please see attached pictures for net.telestream.wirecast.xml and parent folder permissions

    3) I used Wirecast V7.7 before. Of course it is the same PC and account. There is no problem in V7.7 at all. Upgrading to V8.3 or V9.0 (beta) will cause this problem. I installed V 7.7 again today. There was no problem with V 7.7

     

    How should I solve this problem?

    Like
  • Kimihiko Yano

    This is an odd one. I've localized my machine in Japanese, but I'm still unable to reproduce the issue. If you can't reproduce it on another machine, I would say that it's specific to your machine. When we encounter issues that are specific to one machine we usually reimage it with a fresh copy of Windows.

    Like
  • Rory Maloney 

     

    I installed wirecast on 3 PCs I have. But the same problem occurred on all PCs. One of them was a fresh machine that installed win10 today

    There is no problem in V7.7 at all. Upgrading to V8.3 or V9.0 (beta) will cause this problem.

    Like
  • Like
  • Shannon Atkinson

    That's not good, what version of macOS are you on and which version of Wirecast are you running? 

    Like
  • Kimihiko Yano

    We will spend some more time trying to reproduce this behavior, but we've been unsuccessful so far. 

    Like
Replies are closed
Like3
  • 3 Likes
  • 5 mths agoLast active
  • 33Replies closed
  • 1510Views
  • 12 Following