Mute replay default.

Is there any way in WC7 to set the replayclips to be muted by default?

 I want sound on the videofiles for later editing but don't want sound while playing the replayclips live so our commentators can describe whats happening in the replay.

In WC6 I was able to fix this by using a replaytemplate that was muted but that doesn't work in WC7. Muting the replay manually for each replayclip is not an option. 

21replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I can see why that would be useful. Please do fill out the form and note that you were able to create a muted template in 6 but that doesn't work in 7 and you'd like that feature reintroduced.

    Wirecast Feature Request Form

    Reply Like
  • I was looking for the same thing.

    I guess you can go into the audio settings tab in inspector for each replay shot and mute the audio that way, but that could be very annoying to do it every time.

    We would love to see this feature reactivated as well. Record audio on replays for later editing for highlights, but mute during playback in show.

     

    Reply Like
  • Mark Of course send in the feature request form. More voices greater potential influence on development.

    Reply Like
  • I'm there 100% on this feature request.  I use Studio version usually, but looking to use Pro have been testing the Replay functionality with a colleagues PRO.  It clearly records the audio on the clip if you choose a source, but also replays the audio when you want the clip to run.

    Our problem is we have been doing the test Replays in Live Sports broadcasts, so commentators audio on layer 3 (embedded stream coming from vMix or direct from Decklink.) - has to stay on 100% but we don't want the audio for the clip to play at all.  There is no option in the way we use it to be muting clips because the moment I press the Replay button we have it go Auto-Live so it plays the last 10-15 seconds of Game footage.

    Even something as simple as muting at layer level would work.  Or in the Replay/ISO REC configure screen a second tickbox next to the Audio Source chooser "Mute Audio during Replay" or "Mute Replay Audio on AutoLive"

    How do we request this feature?

    Reply Like
  • Leigh Green 

    Leigh Green said:
    How do we request this feature?

     Please do fill out the form I linked to in my first post on this thread.

    Reply Like
  • CraigS Got it - sorry it just looked like a Reply line :) Will do.  

    For the moment I have found some trickery around it...And it also gets around another issue I've been having anyway - with Youtube only wanting 30fps or 60fps and not liking Interlaced footage.
    The issue is that we use Interlace Broadcast cams and when streaming from Wirecast we get a lot of vertical artifacts on fast motion.
    So to get around it I started using vMix to de-interlace the input from 50i to 25p into Wirecast - it has made a difference, but I just found a better solution for that issue when working on this Audio Replay issue.

    I have Video input into vMix as well as Audio from a Behringer FCA1616, output that to Wirecast, do my Replays in Wirecast, have it record the audio, but now instead of streaming in Wirecast I Push it to a Virtual Camera OUT.

    Then in a 2nd vMix instance I pick up the Wirecast Virtual Camera and the Behringer audio (Not the Wirecast Audio.) and the Streaming mechanism in the 2nd instance of vMix pushes to Youtube and the Audio from the Replay is no longer there because I am picking directly from Broadcast source audio as well as the picture is now FULLHD without panning artifacts!

    I Say all this...Big test will be tomorrow's broadcast!

    I WIll fill in the feature request form of course - this very same looping should happen inside of Wirecast instead.

    Reply Like
  •  Leigh Green Wirecast deinterlaces. There's no need to use any other software. All capture cards that handle 1080 that I know of have this feature and it's enabled in Wirecast, usually be default, otherwise just use the tick box. This is the driver that the Blackmagic Decklink uses. 

     

    Reply Like
  • CraigS 


    CraigS Yes I am aware of the option there, and Whether ticking or unticking it makes no difference.  This phenomenon isn't really Interlacing - it is the effect of 5 dropped frames per second and Wirecast/youtube combination trying to make up the difference.  Interlacing will give you the staggered image horizonally with fast side to side motion.  In this case we get vertical artifacts - so an Upright pole rather than looking just fuzzy when Blending is enabled actually shows 2 poles next to each other Both blended but at 50% opacity.
    We worked it out to be the Interlacing/Wirecast/Youtube combination.  The moment I put a consumer cam running at 50p the issue goes away.  I'm not dark on Wirecast by any means with this.  It is Youtube NOT supporting Interlaced footage.  As mentioned if I change the Youtube Upload profile to 25frames it uploads ok but looks terrible, but if I leave it at 30frames I get 5 frames dropped every 5 seconds anyway and the footage looks jerky.
    Anyway - that isn't what this thread was about - sorry for the Hijack OP.

    Reply Like
  •  Leigh Green Yes unfortunately YouTube requires 30fps and that certainly is an issue with PAL compatible workflows. If only YouTube would consider changing that. Otherwise one has to do frame rate conversions or workarounds as you're doing. Many professional cameras are "international" these days so they can be set to NTSC compatible frame rates but then you may have to work around lighting flicker.

    Reply Like
  • CraigS  Hi Craig, I'm using consumer cam 1080 i 50 frame standby mode video input into Magewell dongel converting into usb 3 video into my Mac This option does not show up. having poor video quality in all of my streams. 

    Reply Like
  •  ShooterGeek Check with Magewell's software first. The Magewell dongle is driverless so it would just show up as webcams do. It's always possible you have too many devices on the same bus. Ideally the device should be on its own bus. Often multiple ports are on the same bus, resulting in a bus bandwidth issue.

    Reply Like
  • Hi Craig, yes magewell dongle has NO software and considered as web cam. I have two usb3 and two thunderbolt connections on my macbook pro retina display 2015 model.

    One usb is being used for dongle and other one is for USB audio coming from audio out of my audio mixer.

    Video is going in switcher then coming out of switcher output with multiple options i.e. 720p @30 1080 i or 1080 p @  50 - I've tried all out put options out of switcher output. 

    On preview monitor its perfect & crystal clear but in wirecast, its very blurry & choppy.

    Reply Like
  • ShooterGeek

    While the dongle has not driver, there is software. Magewell Capture Express. You should test the devices with it to make sure they are being captured properly individually.

    Since you are using two Magewell dongles you need to confirm you MBP has two buses. Two ports may be on one bus as well as other devices. You must check that.

    Your description sounds like a system based issue as I haven't seen other reports of this.

     

    Reply Like

  • CraigS I have to apologise to Björn Fröberg for the fact this thread appears to have been hijacked for a completely different issue...
    CraigS is there a way you can migrate our discussion elsewhere?
    ...while I'm here though I have a point on USB/Thunderbolt based capture cards...

    I don't think too many devices on the BUS would be an issue - USB3 can handle up to 5Gbps SD-SDI (and by rights HDMI) at 480i/576i is only around 270Mbps, HD-SDI(HDMI) at 720p, or 1080i is around 1.5Gbps - 1080p60 would be around 3Gbps.  Now although ShooterGeek is mentioning 1080p/50 he has mentioned multiple options, and starting with 1080i/50 - so a single USB3 bus should be plenty enough to handle.

    To me it screams of MAC spec issue (video card.) - CPU (i5 instead of i7) - or frame-rate mismatches, etc.  ShooterGeek  you probably need to identify a few more specs, such as RAM, Camera feed into the Magewells, etc.  Also don't forget, that although it is driverless - there is an AMCAP Filter configuration utility (For windows at least...) which sets the Chipset settings for capture - such as colour space, frame rate, output size, etc.  It may be set to a lower res and WC7 is automatically upscaling it...(default on the Magewell is set to 1920x1080

    Reply Like
  •  Leigh Green  Rather than continue to send this thread off course, Please start a new thread and I can then move the other posts relevant to it as well. Please do ASAP. 

    Reply Like
  • CraigS Thanks Craig, Will check and update. :) 

    Reply Like
  • Leigh Green : Thanks Leigh will check and update :)

    Reply Like
  •  ShooterGeek Thanks.

    Reply Like
  • Wirecast 8 Replay Settings has option to Mute the replay clip later, for live playback with commentary. It’s under the Show in Preview setting.

    Reply Like
  • Excellent. I can't wait. to see it Wirecast 8. Hopefully the glitching issue when using a replay template will be fixed as well. It is very distracting seeing it on many webcasts and also we cannot use the replays as we would like to because of it. 

    Reply Like
  • Mark said:
    Hopefully the glitching issue when using a replay template will be fixed as well.

     Make sure you report that if you haven't already.

    Reply Like
reply to topic
Like Follow
  • 6 mths agoLast active
  • 21Replies
  • 457Views
  • 6 Following