0

Problem using Black Magic ATEM Mini with Wirecast pro v13.02

Hi, 

I have recently purchased a Black Magic Design ATEM Mini to use with wirecast for multiple cameras. I can use it together with the Ultra Studio Mini Recorder on HDMI Out on the ATEM mini but I need this for another external screen. This means I need to use the USB-C out port. This is also necessary to use if you like to use the ATEM Mini software to control the unit. 

Using USB-C lets the incoming video be handles as a webcam in Mac OS. When I plug it into my computer the computer recognizes it fine and for instance Skype and Zoom directly adds an option to choose the ATEM Mini as a webcam. Wirecast however does not find it. 

For some reason Wirecast suddenly found it when I had fiddled around for an hour or so to try to make it work. I have no explanation why but the next time it didn't find it again. 

Is there any support for the ATEM Mini as a webcam in Wirecast. If not; will there be in the future?

Looking forward to your response. 

Thanks and best regards, 

/Michael 

19replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Some users are finding they have to unplug and plug it back in.  Others have found that using Video Capture Show Duplicate Sources works. We're working on fixing this so it will work reliably.
     

    Like
  • Thanks a bunch Craig. I will try this next time otherwise I'll wait for your updates. 

    Like
  • Michael Oddane We should have this fixed soon in an upcoming update.

    Like
  • Michael Oddane  The Wirecast 13.1 beta should have a fix for the problem that the ATEM Mini would not appear in the list of system video and audio devices. 

    Unfortunately, it will appear as separate video and audio devices and their names will be a rather generic "Blackmagic Device", not "Blackmagic ATEM Mini" as you might expect.  The name of the device is determined by the device manufacturer. Wirecast, however, does allow you to change the name that appears within the app itself in the Source Properties section of the inspector UI.

    Like
  • PaulM That is very good news Paul! 

    When can I download the 13.1 Beta and from where?

    Thanks. 

    Like
  • Michael Oddane The Wirecast 13.1 Beta is available now.

     

    Here is a link to the forum post that has all the download information and release notes.

    Like
  • PaulM Thanks a lot. I will try it and let you know how it works. 

    Do I have to uninstall the current version first? 

    Like
  • Michael Oddane

    On Mac you can have more than one version installed at the same time.  On Windows you don't have to uninstall older versions before installing newer versions but you do have to uninstall newer versions before installing older versions.  That's due to the Windows Installer system refusing to overwrite newer files with older ones.

    Like
  • PaulM Ok. Already installed and it works fine. 

    I have had another problem with all versions of Wirecast. After I create a project that have both text and images in it, then save it, close the program and reopens that same file later on the program has very often forgotten the text. It is still there as a layer and I can see the text typed if I go to the area where I type and choose fint etc. But it is not displayed. 

    If I close that same file and reopens it it has forgotten another text and shows the text that was not shown the last time correctly again. If I close the file again and reopens it may show all text correctly that second time. It is completely random but very annoying. 

    It means if I prepare a video in the afternoon or evening that I want to film the day after. I always have to retype the texts. 

    Is there any fix to this. Again; it has been this way several versions now including now the last. 

    Would deeply appreciate a fix to this problem. 

    Thanks, 

    /Michael 

    Like
  • Michael Oddane 

    Glad to hear 13.1 has fixed your ATEM Mini problem.

     

    One other thing about the ATEM Mini:  I suggest capturing the HDMI output of the ATEM as opposed to the USB output.  You get better quality video (uncompressed 422 YCbCr as opposed to JPEG over USB2) and you get better A/V sync assuming you use something like the Ultrastudio Mini or DeckLink Mini Recorder.  Devices that Wirecast communicates with using proprietary API typically allow us to sync the audio and video better than UVC devices which separate audio from video.

     

    WRT your text issue: I have not been able to reproduce the problem.  But let's avoid bloating this thread with issues that are unrelated to the title of this thread.  If you don't mind, please post a separate thread to pursue the problem further and provide detailed steps to help us reproduce the issue including which platform you're running on, which fonts are being used, what other shots are in the project, exactly how many text shots are in the project, where are you not seeing the text (preview, live, and/or shot icons), and roughly what percentage of times you open the project does the problem occur.  Thanks!

    Like
  • Great discussion here guys- thanks PaulM for your help. 

    I've gotten the ATEM Mini to work well via the USB-C connection to Wirecast (had the same initial problems that as well). However my issue is I cannot for the life of my figure out why the ATEM Mini won't connect to the Ultrastudio Mini Recorder? My mini recorders work great if I cannot HDMI out from cameras (Sony a6500) directly into them (or any other HDMI input for that matter, including extra displays etc), but as soon as a I try to connect ATEM Mini HDMI out into Ultrastudio Mini Recorder (and then Thunderbolt 2 into mac) I've only got black screen. 

    The black screen is the same either in Wirecast or in the Blackmagic Media Express software package- any clues as to why this would be the case?

    Thanks,

    - Dw

    Like 1
  • David Williamson said:
    The black screen is the same either in Wirecast or in the Blackmagic Media Express software package- any clues as to why this would be the case?

     Since it's happening in Media Express it may be driver or setting related. BMD updated their driver the other day so update to 11.5 and test with the updated BMD Desktop Video Media Express.

    Like
  • CraigS  am yet to try the above you wrote just yesterday i updated BMD Desktop Video drivers to 11.5. Let me know if BMD Desktop Video can see Atem Mini as a Desktop Video Device cos these drivers too don't recognise it or is it meant to be recognised.

    Like
  • Percy Chikwezvero ATEM Mini USB in does not require a driver. ATEM Mini HDMI out  can use Blackmagic Ultra Studio HDMI to Thunderbolt which does require Blackmagic Driver. If there's an issue with the driver that would be something Blackmagic would need to fix though.

    Like
  • hi @Craigs im getting the same problem. the usb sometimes recognises and sometime it doesn't also when it dos recognise its a hit and miss and  lags, with obs it works fine . i have 13.0.1 version   

    Like
  • Sheikh Nooralom Please update to 13.1.1. Updates include bug fixes and improvements.

    Like
  • CraigS  where do I update it ? As I tried it from wirecast but it's charging me £168 :( ? 

    Like
  • Sheikh Nooralom If you're on our annual support plan updates and upgrades are free done from within Wirecast Preferences Software Update.

    Like
  • I too am having this problem. First time user for both the ATEM Mini and Wirecast. I cant update to 14.0 version as my Mac OS doesn't support it. I've watched videos, read blogs, and tried everything I can think of. I still can't get Wirecast to see my ATEM Mini. 

    Like
Like Follow
  • 7 days agoLast active
  • 19Replies
  • 862Views
  • 8 Following